티스토리 뷰

반응형

 nvidia 그래픽카드중에서 좀 오래된 9600GT를 아직도 사용합니다. 이번에 최신버전으로 드라이버를 업데이트 하면서 정상적으로 작동하지 않고 블랙스크린만 나오는 것을 보고 글을 씁니다.


 최신 그래픽카드는 intel 내장 그래픽과 함께 작동하면서 저전력시에는 intel 내장그래픽을, 고성능을 원하는 작업시에는 nvidia 그래픽카드를 사용하도록 드라이버가 자동으로 지원하는 기능을 제공합니다. (리눅스기반에서 정상적으로 작동하는지 모르겠습니다. 일단 저는 해당 그래픽카드만 정상적으로 작동하는 것이 이번 드라이버 업데이트 목적이니까요..) bumblebee 와 primus 라는 추가 설치가 문제가 되었습니다.


 사용하지도 않는 기능에 대한 프로그램들이 추가 설치되니 정상작동할리가 없지요..


 자 nvidia 의 최신드라이버 저장소를 추가합니다.

$ sudo add-apt-repository ppa:xorg-edgers/ppa


 그리고 저장소 정보를 업데이트 합니다.

$ sudo apt-get update


 저장소 정보가 갱신되었으니 최신버전의 드라이버를 설치합니다. 오늘기준으로 331 버전이 최신버전이네요. current 버전은 아마 304버전인 듯 합니다.

$ sudo apt-get install nvidia-331


 요렇게 설치하면 nvidia-settings 등 부가적으로 필요한 패치키가 전체적으로 설치가 됩니다.


 랩탑(노트북) 사용자가 아닌 한에 그리고 내장 intel 그래픽을 사용하지 않는 사용자는 bumblebee, primus 라는 추가 설치된 패키지를 삭제합니다.

$ sudo apt-get remove --purge bumblebee primus


 이렇게 설치가 마무리되면 리부팅합니다.

 그리고 nvidia 관련 패키지가 어떤 것을 설치되었는지 확인하려면 다음과 같은 명령어를 입력합니다.

$ sudo dpkg -l | grep nvidia


 제 PC에 설치된 패키지 목록을 보여드릴께요.


 위에 보이는 패키지를 제외하고 다른 패키지들은 부가패키지입니다. 이렇게만 설치되어있으면 nvidia 드라이버를 사용하는데 아무 지장이 없습니다.


 끝.

반응형
댓글
댓글쓰기 폼